#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SimpleDate(?:.*):(?:.*?)\"([0-9|-]{1,}T[0-9|:]+Z)"
Local $sString = "@"{" & @CRLF & _
" ""SimpleDate"":""2012-05-18T00:00:00Z""," & @CRLF & _
" ""PatternDate"":""2012-11-07T00:00:00Z""" & @CRLF & _
" }""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")