import Foundation
let pattern = #"SimpleDate(?:.*):(?:.*?)\"([0-9|-]{1,}T[0-9|:]+Z)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@"{
""SimpleDate"":""2012-05-18T00:00:00Z"",
""PatternDate"":""2012-11-07T00:00:00Z""
}"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}