re = /SimpleDate(?:.*):(?:.*?)\"([0-9|-]{1,}T[0-9|:]+Z)/
str = '@"{
""SimpleDate"":""2012-05-18T00:00:00Z"",
""PatternDate"":""2012-11-07T00:00:00Z""
}"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end