$re = '/SimpleDate(?:.*):(?:.*?)\"([0-9|-]{1,}T[0-9|:]+Z)/';
$str = '@"{
""SimpleDate"":""2012-05-18T00:00:00Z"",
""PatternDate"":""2012-11-07T00:00:00Z""
}"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);