package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SimpleDate(?:.*):(?:.*?)\"([0-9|-]{1,}T[0-9|:]+Z)`)
var str = `@"{
""SimpleDate"":""2012-05-18T00:00:00Z"",
""PatternDate"":""2012-11-07T00:00:00Z""
}"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}