using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!?\[([^\]]*)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\. ]+)(\""(.+)\"")?\)";
string input = @"[test](google.com)
[](google.com)
[test](google.com ""hello"")
[test](http://google.com ""hello"")
[test](https://google.com ""hello"")
[multi test](google.com)


";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}