package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!?\[([^\]]*)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\. ]+)(\"(.+)\")?\)`)
var str = `[test](google.com)
[](google.com)
[test](google.com "hello")
[test](http://google.com "hello")
[test](https://google.com "hello")
[multi test](google.com)


`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}