re = /!?\[([^\]]*)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\. ]+)(\"(.+)\")?\)/m
str = '[test](google.com)
[](google.com)
[test](google.com "hello")
[test](http://google.com "hello")
[test](https://google.com "hello")
[multi test](google.com)


'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end