import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!?\\[([^\\]]*)?\\]\\(((https?:\\/\\/)?[A-Za-z0-9\\:\\/\\. ]+)(\\\"(.+)\\\")?\\)";
final String string = "[test](google.com)\n"
+ "[](google.com)\n"
+ "[test](google.com \"hello\")\n"
+ "[test](http://google.com \"hello\")\n"
+ "[test](https://google.com \"hello\")\n"
+ "[multi test](google.com)\n"
+ "\n"
+ "\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}