$re = '/!?\[([^\]]*)?\]\(((https?:\/\/)?[A-Za-z0-9\:\/\. ]+)(\"(.+)\")?\)/m';
$str = '[test](google.com)
[](google.com)
[test](google.com "hello")
[test](http://google.com "hello")
[test](https://google.com "hello")
[multi test](google.com)


';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);