import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^0-9\\. ])";
final String string = "Here is a simple string.\n"
+ "12.345 23.65 Ok this is nice.\n"
+ "Kh <- hmm dont work like that.";
final String subst = " \\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}