import re
regex = re.compile(r"([^0-9\. ])", flags=re.MULTILINE)
test_str = ("Here is a simple string.\n"
"12.345 23.65 Ok this is nice.\n"
"Kh <- hmm dont work like that.")
subst = " \\1 "
result = regex.sub(subst, test_str)
if result:
print(result)