// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^0-9\. ])").unwrap();
let string = "Here is a simple string.
12.345 23.65 Ok this is nice.
Kh <- hmm dont work like that.";
let substitution = " \\1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}