re = /([^0-9\. ])/m
str = 'Here is a simple string.
12.345 23.65 Ok this is nice.
Kh <- hmm dont work like that.'
subst = ' \\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result