$re = '/([^0-9\. ])/m';
$str = 'Here is a simple string.
12.345 23.65 Ok this is nice.
Kh <- hmm dont work like that.';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;