using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/plus\.google\.com.+\+(.+)";
string input = @"https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\/\/plus\.google\.com\/([^\/]*)
#хватает только ""u""
https?:\/\/(www\.)?instagram\.com\/([^\/].+)
#instagram режет: ""username/"" - как убрать в конце ""/"" ?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}