import Foundation
let pattern = #"https:\/\/plus\.google\.com.+\+(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\/\/plus\.google\.com\/([^\/]*)
#хватает только "u"
https?:\/\/(www\.)?instagram\.com\/([^\/].+)
#instagram режет: "username/" - как убрать в конце "/" ?
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)