# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/plus\.google\.com.+\+(.+)"
test_str = ("https://plus.google.com/u/0/+Username\n"
"https://plus.google.com/u/2/Username/posts\n\n"
"https?:\\/\\/plus\\.google\\.com\\/([^\\/]*)\n"
"#хватает только \"u\"\n\n"
"https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/].+)\n"
"#instagram режет: \"username/\" - как убрать в конце \"/\" ?")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.