const regex = /https:\/\/plus\.google\.com.+\+(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/plus\\.google\\.com.+\\+(.+)', 'g')
const str = `https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\\/\\/plus\\.google\\.com\\/([^\\/]*)
#хватает только "u"
https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/].+)
#instagram режет: "username/" - как убрать в конце "/" ?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}