// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https:\/\/plus\.google\.com.+\+(.+)").unwrap();
let string = "https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\\/\\/plus\\.google\\.com\\/([^\\/]*)
#хватает только \"u\"
https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/].+)
#instagram режет: \"username/\" - как убрать в конце \"/\" ?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}