#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\\u[a-z0-9]{4}"
Local $sString = "This is a pragraph \ud83d having some emojis like these ones:" & @CRLF & _
"" & @CRLF & _
"\ude04" & @CRLF & _
"" & @CRLF & _
"\ud83d" & @CRLF & _
"" & @CRLF & _
"\ude04" & @CRLF & _
"" & @CRLF & _
"Have you seen them?" & @CRLF & _
"" & @CRLF & _
"\ud83d\ude04" & @CRLF & _
"" & @CRLF & _
"Great!" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")