package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\\u[a-z0-9]{4}`)
var str = `This is a pragraph \ud83d having some emojis like these ones:
\ude04
\ud83d
\ude04
Have you seen them?
\ud83d\ude04
Great!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}