using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\u[a-z0-9]{4}";
string input = @"This is a pragraph \ud83d having some emojis like these ones:
\ude04
\ud83d
\ude04
Have you seen them?
\ud83d\ude04
Great!
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}