re = /\\u[a-z0-9]{4}/i
str = 'This is a pragraph \\ud83d having some emojis like these ones:
\\ude04
\\ud83d
\\ude04
Have you seen them?
\\ud83d\\ude04
Great!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end