import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\u[a-z0-9]{4}";
final String string = "This is a pragraph \\ud83d having some emojis like these ones:\n\n"
+ "\\ude04\n\n"
+ "\\ud83d\n\n"
+ "\\ude04\n\n"
+ "Have you seen them?\n\n"
+ "\\ud83d\\ude04\n\n"
+ "Great!\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}