using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"variable1=([^&]*?)&variable2=([^&]*?)";
string input = @"script.php?variable1=value1&variable2=value2&variable3=value3&.........................";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}