$re = '/variable1=([^&]*?)&variable2=([^&]*?)/';
$str = 'script.php?variable1=value1&variable2=value2&variable3=value3&.........................';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);