re = /variable1=([^&]*?)&variable2=([^&]*?)/
str = 'script.php?variable1=value1&variable2=value2&variable3=value3&.........................'
# Print the match result
str.match(re) do |match|
puts match.to_s
end