const regex = /variable1=([^&]*?)&variable2=([^&]*?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('variable1=([^&]*?)&variable2=([^&]*?)', '')
const str = `script.php?variable1=value1&variable2=value2&variable3=value3&.........................`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}