using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*?Invoice does not foot Reported.*$|^(?!Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*).+";
string input = @"Line : 1 Invoice does not foot Reported
Line : 2 Could not parse INVOICE_DATE value
Line 3 : Could not parse ADJUSTMENT_AMOUNT value
Line 4 : MATH ERROR
cl_id is a required field
File Error : The file does not contain delimiters
lf_name is a required field";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}