import Foundation
let pattern = #"^Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*?Invoice does not foot Reported.*$|^(?!Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Line : 1 Invoice does not foot Reported
Line : 2 Could not parse INVOICE_DATE value
Line 3 : Could not parse ADJUSTMENT_AMOUNT value
Line 4 : MATH ERROR
cl_id is a required field
File Error : The file does not contain delimiters
lf_name is a required field
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)