use strict;
my $str = 'Line : 1 Invoice does not foot Reported
Line : 2 Could not parse INVOICE_DATE value
Line 3 : Could not parse ADJUSTMENT_AMOUNT value
Line 4 : MATH ERROR
cl_id is a required field
File Error : The file does not contain delimiters
lf_name is a required field';
my $regex = qr/^Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*?Invoice does not foot Reported.*$|^(?!Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*).+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}