# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*?Invoice does not foot Reported.*$|^(?!Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*).+"
test_str = ("Line : 1 Invoice does not foot Reported\n"
"Line : 2 Could not parse INVOICE_DATE value\n"
"Line 3 : Could not parse ADJUSTMENT_AMOUNT value\n"
"Line 4 : MATH ERROR\n"
"cl_id is a required field\n"
"File Error : The file does not contain delimiters\n"
"lf_name is a required field")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.