$re = '/^Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*?Invoice does not foot Reported.*$|^(?!Line\s(?:(\d+)\s)?\s*:\s+(\d+)?.*).+/m';
$str = 'Line : 1 Invoice does not foot Reported
Line : 2 Could not parse INVOICE_DATE value
Line 3 : Could not parse ADJUSTMENT_AMOUNT value
Line 4 : MATH ERROR
cl_id is a required field
File Error : The file does not contain delimiters
lf_name is a required field';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);