# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#.*:|~.*//g;t' <<< "#,0000:10100010~;1000_0101;1001_0110;1010_0111;1011_1000;1100_1001;1101_1010;1110_1011;1111_1100,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,"