// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#.*:|~.*").unwrap();
let string = "#,0000:10100010~;1000_0101;1001_0110;1010_0111;1011_1000;1100_1001;1101_1010;1110_1011;1111_1100,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}