#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "#.*:|~.*"
Local $sString = "#,0000:10100010~;1000_0101;1001_0110;1010_0111;1011_1000;1100_1001;1101_1010;1110_1011;1111_1100,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)