using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\s*prima\s*1\s*(?!\d+\s+)\S+(?:\s+(?!\d+\b)\S+)*\s*2\s+(?!\d+\b)\S+(?:\s+(?!\d+\b)\S+)*\s*$";
string input = @"] prima 1 *words* 2 *words* excluding 3
] prima 1 *words* → 2 *words* excluding 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}