import re
regex = re.compile(r"\]\s*prima\s*1\s*(?!\d+\s+)\S+(?:\s+(?!\d+\b)\S+)*\s*2\s+(?!\d+\b)\S+(?:\s+(?!\d+\b)\S+)*\s*$", flags=re.MULTILINE)
test_str = ("] prima 1 *words* 2 *words* excluding 3\n"
"] prima 1 *words* → 2 *words* excluding 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")