import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\s*prima\\s*1\\s*(?!\\d+\\s+)\\S+(?:\\s+(?!\\d+\\b)\\S+)*\\s*2\\s+(?!\\d+\\b)\\S+(?:\\s+(?!\\d+\\b)\\S+)*\\s*$";
final String string = "] prima 1 *words* 2 *words* excluding 3\n"
+ "] prima 1 *words* → 2 *words* excluding 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}