$re = '/\]\s*prima\s*1\s*(?!\d+\s+)\S+(?:\s+(?!\d+\b)\S+)*\s*2\s+(?!\d+\b)\S+(?:\s+(?!\d+\b)\S+)*\s*$/m';
$str = '] prima 1 *words* 2 *words* excluding 3
] prima 1 *words* → 2 *words* excluding 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);