const regex = /\]\s*prima\s*1\s*(?!\d+\s+)\S+(?:\s+(?!\d+\b)\S+)*\s*2\s+(?!\d+\b)\S+(?:\s+(?!\d+\b)\S+)*\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\]\\s*prima\\s*1\\s*(?!\\d+\\s+)\\S+(?:\\s+(?!\\d+\\b)\\S+)*\\s*2\\s+(?!\\d+\\b)\\S+(?:\\s+(?!\\d+\\b)\\S+)*\\s*$', 'gm')
const str = `] prima 1 *words* 2 *words* excluding 3
] prima 1 *words* → 2 *words* excluding 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}