#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<name>[\w\s]+)(?: <(?P<email>[^>]+)>)?$"
Local $sString = "John Doe <john.doe@example.com>" & @CRLF & _
"John Doe <john.doe!!!???äöu@exämple.com>" & @CRLF & _
"" & @CRLF & _
"John Doe<john.doe@example.com>" & @CRLF & _
" <john.doe@example.com>" & @CRLF & _
"john.doe@example.com" & @CRLF & _
"John Doe john.doe@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")