$re = '/^(?P<name>[\w\s]+)(?: <(?P<email>[^>]+)>)?$/m';
$str = 'John Doe <john.doe@example.com>
John Doe <john.doe!!!???äöu@exämple.com>
John Doe<john.doe@example.com>
<john.doe@example.com>
john.doe@example.com
John Doe john.doe@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);