const regex = /^(?P<name>[\w\s]+)(?: <(?P<email>[^>]+)>)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<name>[\\w\\s]+)(?: <(?P<email>[^>]+)>)?$', 'gm')
const str = `John Doe <john.doe@example.com>
John Doe <john.doe!!!???äöu@exämple.com>
John Doe<john.doe@example.com>
<john.doe@example.com>
john.doe@example.com
John Doe john.doe@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}