re = /^(?P<name>[\w\s]+)(?: <(?P<email>[^>]+)>)?$/m
str = 'John Doe <john.doe@example.com>
John Doe <john.doe!!!???äöu@exämple.com>
John Doe<john.doe@example.com>
<john.doe@example.com>
john.doe@example.com
John Doe john.doe@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end