using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href=""|src="")(?!https?:\/\/)[^""]*";
string input = @"<a href=""joycat""></a>
<a src=""joycat""></a>
<a href=""http://joycat""></a>
<a src=""http://joycat""></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}