re = /(?<=href="|src=")(?!https?:\/\/)[^"]*/
str = '<a href="joycat"></a>
<a src="joycat"></a>
<a href="http://joycat"></a>
<a src="http://joycat"></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end