$re = '/(?<=href="|src=")(?!https?:\/\/)[^"]*/';
$str = '<a href="joycat"></a>
<a src="joycat"></a>
<a href="http://joycat"></a>
<a src="http://joycat"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);