import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=\"|src=\")(?!https?:\\/\\/)[^\"]*";
final String string = "<a href=\"joycat\"></a>\n"
+ "<a src=\"joycat\"></a>\n"
+ "<a href=\"http://joycat\"></a>\n"
+ "<a src=\"http://joycat\"></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}